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Essentials Installation

The document contains instructions on how to install Zetadocs for NAV Delivery and Capture Essentials, users
installing point solutions or SDK features should refer to the documentation specific for those products after
completing the Essentials Install. The  Essentials setup installs the core Zetadocs components onto the server and
client machines and also adds the Zetadocs objects and interfaces into NAV. As such all users should complete
these steps regardless of whether they are installing Delivery, Capture or any of the advanced Plus solutions. Before
you begin your installation you should check for the latest software updates, tools and advice to ensure you have
everything you need.

Installation steps to be performed on the server or servers

1. Installing the Zetadocs for NAV Client
2. Setting up the Archive
3. Importing the Objects and Interfaces
4. Importing the Configuration File

Installation steps to be performed on each client machine

Note: Should only be completed after the server install.
1. Installing the Zetadocs for NAV Client
2. Testing the Zetadocs for NAV Solution

1. Installing the Zetadocs for NAV Client

Zetadocs for NAV needs to be installed onto the server as well as any required client machines once the server
install is complete. 

Platform Specific Steps: Please review the additional information available in the Zetadocs for NAV Knowledgebase
if you are installing on Terminal Services or Group Policy.

Extract and run the Zetadocs for NAV product download.
Choose install option based on your requirements:
o Zetadocs Delivery
o Zetadocs Capture
o Zetadocs Delivery and Capture 

Select the Latest Install Notes option to ensure you have the latest advice and tools.
Next select the Zetadocs NAV Client option and the choose the installation language and click Install. 
Proceed through the wizard, review and accept the license agreement and you will be prompted to select the
Install Type, choose from the following:
o Typical - Recommended for additional client installs.
o Administrator - Recommended for server installs, includes all components including the licensing and

configuration application.
o Custom - Allows you to specify the install locations for Delivery and Capture components.

If you are installing on the server machine and select the Administrator install type then you will be asked to
create the templates folder, select a location and select Next to continue. 
Complete the wizard to finish the install of the Zetadocs for NAV Client.

http://www.equisys.com/support/knowledgebase/zdnav.htm
http://www.equisys.com/support/knowledgebase/zdnav.htm
http://www.equisys.com/support/knowledgebase/zdnav.htm
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Installing the Web Client Document FactBox Add-in (NAV 2013 R2 only)

Follow these instructions to add the NAV 2013 R2 Web Client Document FactBox.

1. Stop the NAV Server instance: 
Typically: Microsoft Dynamics NAV Server [DynamicsNAV71] 

2. Locate your product download and select the Zetadocs folder from the folder below: 
\Zetadocs for NAV\Zetadocs NAV Server Components

3. Copy the Zetadocs folder to the NAV Server Add-ins folder: 
Typically: C:\Program Files\Microsoft Dynamics NAV\71\Service\Add-ins

4. Restart the NAV Server instance. 

Install Zetadocs for NAV Help Files

Help provision is handled differently depending on the version of NAV and the client that is being used, please
follow the steps below relating to your NAV version.  

NAV2013 R2 and the Help Server 
NAV 2013 R2 saw the introduction of the NAV help server, to enable your users to access the Zetadocs help files this
must be installed. Please see your NAV 2013 R2 install documentation for details on how to setup the NAV Help
Server.

To integrate the Zetadocs help files with the Microsoft Dynamics NAV Help you need to copy the Zetadocs help files
into the main NAV help file folder and update the table of contents file to enable your users to locate the help they
need.

Locate your product download and select all of the files present from the folder below:
 \Documentation\NAV 2013 R2 Help

Copy these to the NAV Help Server folder:
Typically:  C:\inetpub\wwwroot\DynamicsNAV71Help\Help\<languagecode>

This adds the help files into the server where they can be accessed by pressing F1 on a Zetadocs field, a further
step is required to add them to the Table of Contents so the content can be easily browsed for. 
Open the ToC_Additions.xml in file in a suitable editor and copy the contents and paste them into the ToC.xml file
near the bottom, above the code shown below and Save the changes.

 <Node Name="CopyrightTrademarks" DisplayName="Copyrights and Trademarks"
Page="oriCopyrightTrademarks.htm" />
  </Node>

NAV2013 and earlier - Windows Client/Role Tailored Client 
The Zetadocs for NAV help files need to be copied to the Microsoft Dynamics NAV help folder on each machine. The
file names should use the first unused post-fix letter between a and j (e.g. change to addin_b.chm and addin_b.hh if
addin_a.chm exists). The destination of these files is determined by the install language e.g. substitute the en-GB
subfolder shown in the examples below for the language pertinent to the install e.g. en-US for US systems.

There are 2 files to copy a .chm file and accompanying .hh file which are available from your product download in
the folder:

 \Zetadocs NAV Client\NAV Help

For NAV 6.o systems copy to: Program Files (x86)\Microsoft Dynamics NAV\60\RoleTailored Client\en-GB
For NAV 2013 systems copy to: Program Files (x86)\Microsoft Dynamics NAV\70\RoleTailored Client\en-GB

addin_a.hh - Should be copied to:

For NAV 6.o systems copy to: Program Files (x86)\Microsoft Dynamics NAV\60\Service\ENG
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For NAV 2013 systems copy to: Program Files\Microsoft Dynamics NAV\70\Service\ENG

You may need to restart the Microsoft Dynamics NAV server to get the help files to appear.
Go to Start > Run, type services.msc, and then press ENTER.
Under Services, right-click Microsoft Dynamics NAV Server, and then click Restart.

NAV2013 and earlier - Development Environment/Classic Client
The Zetadocs for NAV help files need to be copied to the Microsoft Dynamics NAV help folder on each machine. The
file names should use the first unused post-fix letter between a and j (e.g. change to addin_b.chm and addin_b.hh if
addin_a.chm exists). The destination of these files is determined by the install language e.g. substitute the en-GB
subfolder shown in the examples below for the language pertinent to the install e.g. en-US for US systems
There are 2 files to copy a .chm file and accompanying .hh file which are available from your product download in
the folder:

 \Zetadocs NAV Client\NAV Help\NAV 5 and 6

For NAV 5.o systems copy to: Program Files\Microsoft Dynamics NAV\CSIDE Client\ENG
For NAV 6.o systems copy to: Program Files\Microsoft Dynamics NAV\60\Classic\ENG
For NAV 2013 systems copy to: Program Files\Microsoft Dynamics NAV\70\Service\ENG

You may need to restart the Microsoft Dynamics NAV server to get the help files to appear.
Go to Start > Run, type services.msc, and then press ENTER.
Under Services, right-click Microsoft Dynamics NAV Server, and then click Restart.

Configuring Zetadocs Licensing

Zetadocs Client Licensing and Setup
Launch the Zetadocs PDF Configuration and choose the license location (General Tab).
o Active Directory (requires that user has access rights to write to AD)
o Shared Network Folder 

Enter your Zetadocs license number, company name and click Register Online and follow the onscreen steps.
Following registration you will be provided with a registration key by email, enter the key to continue.
Add the required users.
Set up a shared network folder in the client for the NAV Templates, use the location specified earlier in the install. 
Leave Network Archiving off as you will configure archiving settings in NAV later in the install.

Zetadocs Client
Start the Zetadocs Client, if using Active Directory licensing, Zetadocs should locate the license automatically,
otherwise, go to Tools> Options> Licensing and enter the path to the network folder containing the Zetadocs
license.
Restart the client if necessary, you can confirm that you are successful if the splash screen shows the Automation
tag beside the number of users.

Please refer to the Zetadocs Client Help for further information on configuring the Zetadocs Client.

2. Setting up your Archive

Zetadocs provides two options for of archiving your documents, you can archive either to SharePoint using the
Zetadocs SharePoint Extensions or you can use the  Zetadocs Archive which allows you to archive files to a Network
folder.

SharePoint Archive

To archive documents to SharePoint you need to add the Zetadocs SharePoint extensions to your SharePoint site,
this enables Zetadocs to archive documents with an array of metadata. This allows Zetadocs to identify and
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associate documents in SharePoint with NAV records as they pass through the sales and purchase processes,
enabling users to access the relevant documents quickly and easily.

Prerequisites
Microsoft SharePoint Foundation 2010/2013
Microsoft SharePoint 2010/2013
Microsoft SharePoint Online
64-bit Systems require the Adobe PDF IFilter be installed, details can be found here.

Adding the Zetadocs SharePoint Extensions
Log into SharePoint as a Site Collection Administrator.
For SharePoint 2013 systems: Select the Cog dropdown menu and choose Site Settings before selecting Solutions
in the Web Designer Galleries section.
For SharePoint 201o systems: On the Site Actions menu, click Site Settings.
For all version now click Solutions, and on the ribbon select Solutions and then Upload Solution.
Locate the Zetadocs SharePoint Extensions folder of your product download and select the Zetadocs SharePoint
Extensions.wsp file.
Upload it and then click on Activate.
Select Site Settings and then Manage Site Features.
Activate the Zetadocs elements in the following order:
o Zetadocs Content Type 
o Zetadocs Document Library
o Zetadocs Workflow (Note: Do not activate this item if using Office 365 Small Business or SharePoint

Foundation)

Enabling the Zetadocs Workflows (Optional)
Zetadocs Workflow is an optional feature that enables a SharePoint document workflow for each captured
document. Zetadocs Payables Approval is designed for companies wanting to offer web based approvals of their
NAV purchase documents. If you are intending to use SharePoint based document approval you will need to enable
the Zetadocs Workflow using the steps below.
Note: Not available on Office 365 Small Business packages and SharePoint Foundation

In your Zetadocs document library select the Add document option.
Upload a document, select it and select Workflows and then start the Zetadocs Workflow. 
Once it has been started you can either cancel or complete the approval process for it.

Zetadocs Archive

The Zetadocs Archive Service runs on a server machine on your network and handles the archiving of documents
captured and sent using Zetadocs. The Zetadocs Archive Service makes use of a SQL database to store the
metadata and act as an index for the archive to allow searching for documents by any metadata field.

Creating the Zetadocs Archive Folder
The archive requires a network folder into which captured documents are placed and to which users require access
permissions. 

Create a folder with the name Zetadocs Archive, the Zetadocs Archive Service searches for this exact name and
will not work with any other naming.
Ensure this location has sufficient disk space, a technical note is available here should you need assistance
determining your requirements.
View the folders Properties and select the Share tab, followed by Advanced Sharing.
Check the Share this folder checkbox and add the share name Zetadocs Archive.
Select the Permissions button and add required users and groups:
o All users of Zetadocs require Read permissions, add these individually or create a Zetadocs group.
o The Zetadocs Archive Service must have access to the folder, by default it runs as Local System and for it to

function correctly the system account requires FULL permissions. 
Next return to the Properties for the folder and select the Security tab.
Select the Edit… button and in the window which appears select Add…

http://www.adobe.com/support/downloads/detail.jsp?ftpID=4025
http://www.equisys.com/solutions/payables_approval.html
http://www.equisys.com/technotes/ztn4290.htm
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o All users of Zetadocs require Read permissions, add these individually or as a group.
o The Zetadocs Archive Service must have access to the folder, by default it runs as Local System and for it to

function correctly the system account requires FULL permissions. 

Installing the Service
Note: If you are running on Windows Server 2003 you must carry out the additional steps in this technical note
before proceeding with the steps below.

Locate the Zetadocs Archive Service folder of your product download and run the setup.exe file.
Note: The Zetadocs Archive Service installer may require you to reboot your server to complete. 
The installer performs the following actions:
o Installs SQL Express (or adds a new instance if already installed)
o Creates the SQL database for indexing and metadata
o Installs the Zetadocs Archive Service

Proceed through the wizard following the on screen prompts to complete the installation.

Connecting the Zetadocs Archive Service and Zetadocs Archive folder 
If you have setup the Zetadocs Archive folder on a different server to the Zetadocs Archive Service you now need to
carry out the steps below to ensure the service can access the folder. If they are on the same server machine this is
not required.

Locate the Zetadocs Archive Service\Scripts folder of your product download and run the
SetArchiveFolderLocation.cmd file.
In the window which appears enter the server name where the Zetadocs Archive folder is located.
Next you need to ensure that the user the Zetadocs Archive Service is running as is a domain user. 
To do this open Users and Groups, or the equivalent on the operating system you are using.
Select Users and then New User… from the Action menu.
Give the account a suitable user name, full name and description.
Enter a password for the account and ensure the Password never expires checkbox is selected before clicking
Create.
Next go to your Zetadocs Archive folder and view its Properties and select the Share tab, followed by Advanced
Sharing.
Select the Permissions button and add your newly created user account with FULL permissions. 
Next return to the Properties for the folder and select the Security tab.
Select the Edit… button and in the window which appears select Add…
Add the users and groups you created earlier to grant your users and the Zetadocs Archive Service access to the
Zetadocs Archive folder.
Open the services list and locate the Zetadocs Archive Service, stop the service before right-clicking and selecting
Properties.
View the Log On tab and check the This account radio button, click Browse… and select your recently created user
account. 
Enter the password details and click OK before restarting the service running as the new user.

3. NAV Objects and Interfaces

This section details how to import the objects used by Zetadocs into NAV in addition to a number of modifications
which need to be done to some existing NAV interfaces and reports. Tools are available to automate this process as
much as possible, which may not be suitable for heavily modified objects, should that be the case manual steps are
also available.

Prerequisites
Suitable NAV licence for importing NAV objects.
Logged in with sufficient permissions and developer license.
The Windows Script Control ActiveX control needs to be installed.

http://www.equisys.com/technotes/ztn4299.htm
http://www.equisys.com/technotes/ztn4275.htm
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Creating a test NAV system

It is recommended that you perform the importation of the NAV objects and configuration data on a duplicate of your
live database, this can then be exported and transferred onto the live system once you are confident that it is
working as expected. 

Backing up the existing NAV Objects
In order to be able to uninstall Zetadocs for NAV software it is necessary to backup the NAV objects before installing
the Zetadocs for NAV objects. 

Open the Object Designer (Tools > Object Designer). 
Click on All button in the designer menu. 
Select All objects and export them, File > Export.
Export the objects and store the file in a safe location.

Importing the Zetadocs for NAV Objects

Open the NAV Development Environment (Classic Client) and the relevant database.
From the object designer import the fob file by selecting File > Import.
Browse to your product download and navigate to  Zetadocs NAV Server Components\ folder.
Choose the object file relevant to your NAV version.

NAV Version Fob file to use

NAV 5.00 Zetadocs for NAV Objects – NAV5.00.fob

NAV 6.01 (2009 SP1) Zetadocs for NAV Objects - NAV6.01.fob

NAV 6.10 (2009 R2) Zetadocs for NAV Objects - NAV6.10.fob

NAV 7.00 (NAV2013) Zetadocs for NAV Objects – NAV7.00.fob

NAV 7.10 (NAV2013 R2) Zetadocs for NAV Objects – NAV7.10.fob

Assuming there are no collisions with existing objects continue importing the objects and ensure that there have
been no compilation errors. 

Note: If upgrading from Zetadocs Express there will be some collisions, and you will be presented with the NAV
Import Worksheet. Please accept the default actions and click OK to continue with the import.

Zetadocs Interface Modification Tool

Zetadocs requires several existing NAV interfaces to be modified to add Zetadocs functionality, to make this process
quicker and easier we have provided the Zetadocs Interface Modifier tool. This can update the NAV v5.x, v6.x and 7.x
objects so that they can integrate with Zetadocs, the tool will inform you if there are any issues, for example if the
objects have too extensive a set of existing customizations, in which case manual steps are available.

Download the Interface Modification Tool and extract it.
Open the object designer and choose the All tab.
Click on the Table Filter and add these filters to select those objects which need modifying to support Zetadocs
integration:
o Type: Form|Page, Note: Forms are not compatible with NAV 7.0.
o ID: 21|26|41..44|49..52|130|132|134|136|138|140|507|509|6630|6640|6650|6660

Apply the filter and review the list, systems utilising Sales reports require the customer card and likewise those
with Purchasing reports require the vendor card be included but the remaining objects can be selected based on
which you wish to add Zetadocs support for. 
Select the required objects and go to File > Export and save the interfaces as an XML file (NAV 6.x) or as a TXT
file (NAV 5.x and NAV 7.x)
Open the ZdNAVInterfaceTool - Full.exe file and click on Load Items, you will be asked to specify your NAV version
and language.
Browse to the location of your exported Interfaces file and click Open, the tool will load your exported items, click

http://www.equisys.com/technotes/ztn4275.htm
http://www.equisys.com/support/knowledgebase/zdnav.htm
http://www.equisys.com/support/knowledgebase/zdnav.htm
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Start.
The tool will then prompt you to decide whether to include the Rules action to the Customer and Vendor cards. 
Invalid items are reported in a message dialog after the load operation has completed and should be processed 
manually.
The status column shows the conversion process. If an item cannot be modified, the reason will be listed in this
column, in which case follow the manual instructions.
The updated file name will be appended (Modified) and is available in the folder containing the original interfaces
file.
Invalid items are reported in a message dialog after the load operation has completed and should be processed
manually.
Re-import the modified pages and forms into NAV and deal with any merge and conflict messages that may
appear, before compiling them (F11).

Zetadocs Report Modification Tool

Note: These sections are only required for Zetadocs Delivery, those only installing Capture Essentials can continue
from importing the configuration.
Each report you wish to deliver with Zetadocs also needs to be modified to enable Zetadocs functionality, to
facilitate this we have provided the Zetadocs Report Modification Tool.

Prerequisites
Compatible with NAV 5.x, 6.x and 7.x Classic Client or Development Environment.
The Tool is not guaranteed to work for all NAV reports, in which case manual steps are also available in the
Zetadocs knowledgebase.
The tool does not perform all the changes required for Windows Client reports, to adjust Windows Client reports
we recommend running the reports through the tool and then performing the additional edits detailed below.

Using the Report Tool
Download the Report Modification Tool and extract it.
Open the Object Designer and select the reports you wish to add Zetadocs functionality to and export them as a
text file.
Run the Tool and click Load Reports before selecting the version of NAV.
Browse to your exported reports and click Start and the Conversion Options window will appear. 
Modify the new report ID range as required. 
o This specifies the starting ID that the Report Modification Tool will use for the first modified report. Subsequent

reports will use values incremented from this base value.
Modify the report name prefix, as required. 
o This specifies a 0 to 3 character prefix that all reports will have appended to their names. This ensures the

reports have a unique name. Leaving the prefix blank will allow the existing report name to be used, however,
you may get name collisions if you have chosen to use new report IDs as well.

You may be asked to delete the existing output directory, you may wish to back up this directory before
proceeding.
If a report cannot be modified, the reason will be listed. For successful conversions, the new report ID and report
name are given.
The modified reports are now available in the folder containing the original reports, in an Output subfolder.
Reimport the reports and deal with any merge and conflict messages that appear.

Windows Client layout modifications

If you are using the Windows Client with NAV 2009, 2013 or 2013 R2 then you need to perform these additional steps
to ensure the Zetadocs reference is added to the report. There are two different methods to do this depending on
how it has been designed and the version of NAV in question. Most can use the header and body section
modifications detailed below but some reports like the remittance advice journal require the body only
modifications.

NAV 2009/2013/2013 R2 modifying the Header and Body section
The Order confirmation report is an example where the page header section is used to display header information

http://www.equisys.com/technotes/ztn4275.htm
http://www.equisys.com/technotes/ztn4275.htm
http://www.equisys.com/technotes/ztn4275.htm
http://www.equisys.com/support/knowledgebase/zdnav.htm
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on each page for the record.  When this is the case, follow the instructions below to add the Zetadocs reference.

Locate the report and click View > Layout to open the report designer.
Add a new text box in the top left of the body section, ensuring it does not overlap any existing controls. 
Existing text boxes have a parent listbox called list1. If this is the case then ensure that this new textbox has the
same.
Adjust the properties as follows:
o Name: Zetadocs_Reference_tb.
o Value: =Fields!Zetadocs_Reference.Value.
o Visibility Hidden: TRUE.
o Color: Red.

Open the Document Outline – Report window (Visual Studio  >  View  >  Other Windows  >  Document
Outline). 
Locate and cut the Zetadocs_Reference_tb texbox. 
Right click on the list1_Contents node from the document outline Report and select paste then click the Bring to
front button. 
Next, add a new text box to the top left of the page header section of the report ensuring the textbox does not
overlap any existing controls and that the whole 15 digit ZD Reference will fit in the text box on one line.
Adjust the properties as follows:
o Font size: 6 (4 being the minimum)
o Color: White
o Value: =ReportItems!Zetadocs_Reference_tb.Value.

Close and save the report.

Version Code
Once you have saved the report add EQ6.0 to the Version List column in the Object Designer. 

NAV 2009 modifying the Body section only
The remittance advice journal report is an example of a report that does not have a page header section.  When this
is the case, follow the instructions below to add the Zetadocs reference.

Click View > Layout to open the report designer for Windows Client reports.
Add a new text box into the top left  of the header section ensuring the textbox does not overlap any existing
controls.
Usually existing text boxes have a parent listbox called list1. If this is the case then ensure that this new textbox
has the same.
Adjust the properties as follows:
o Font size: 6 (4 being the minimum)
o Color: White
o Value: =Fields!Zetadocs_Reference.Value.

Close and save the report.

Version Code
Once you have saved the report add EQ6.0 to the Version List column in the Object Designer. 

Zetadocs Sample Templates

Zetadocs comes with a number of sample templates, it is usually simpler to modify these to match your
requirements than to create new ones. The English language versions of the templates will have been copied to the
Shared Network Folder you created during the client installation, if you are installing your system in another
language simply follow the steps below to replace these with the translated templates.

Browse to your product download then Zetadocs NAV Server Components\Sample Templates\.
Select the language required and copy the templates to the Shared Network folder you created during the client
installation for the templates. The default location is:

\\<machine name>\Zetadocs Templates
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4. Importing the Configuration File

Zetadocs comes equipped with a standard configuration file which you must import, as it populates NAV with the
base settings Zetadocs requires, once you have completed the import you should have a basic working Delivery
Essentials system. 

Importing the Language Module

If you are intending to use a language other than English, you will need to import the relevant language module,
using the steps below. 
Note: If you are using NAV 2013 R2 you must carry out the additional steps in this technical note before proceeding
with the steps below.

In the object designer select the All view. 
Then using a table filter Version = EQ* to list all the Zetadocs objects.
Select all the highlighted objects and click Tools > Language module > Import.
Browse to the Zetadocs NAV Server Components\Language Modules\ folder of your product download.
Import the language module for your region and version of NAV e.g. for a Dutch NAV 2013 system this would be the
Zetadocs for NAV Language Module – NAV7.xxNL.flm.

Importing the Zetadocs Standard Configuration Data

NAV 2013 and NAV 2013 R2
Open the Windows Client and in the Navigation Pane select Departments  >  Administration > Application Setup
> Zetadocs Setup  >  Zetadocs General Settings.
A message may appear informing you that the Windows Client needs permission to run the
Zetadocs.ExternalUtilities.ZdAutomationFactory, select Always Allow and then OK.
Next select Actions and then Import Configuration Data. 
On the import dialog, provide a path to the templates should you be using a location other than the default.

NAV 2009
Right click on the Navigation Pane and select Refresh or close and then open NAV to update the menusuite with
the changes imported earlier.
Select Administration > Application Setup > Zetadocs Setup. 
Run the Zetadocs General Settings Form.
Select Functions > Import Configuration Data.

Common Steps
Browse to Zetadocs NAV Server Components\Standard Configuration Data folder of your product download.
Select the relevant xml file, e.g. for English it would be \Zetadocs NAV Server Components\Standard Configuration
Data\Zetadocs for NAV Configuration – English.xml and click Import.
A pair of warning messages will appear, select Yes to continue.
NAV 2013 users should click Import on the Home tab. You will be asked to confirm that you wish to import the data,
as it will overwrite any existing data in these tables.

Archive Settings
Next if you are archiving documents using Zetadocs you need to select your preferred method.
o Off - Zetadocs will not attempt to archive items.
o SharePoint - This enables the SharePoint configuration settings which Zetadocs will use to archive your

documents.
o Zetadocs Archive - This enables Zetadocs Archive Service address field, this needs to point to the Zetadocs

Archive Service installed when setting up your archive.

http://www.equisys.com/technotes/ztn4301.htm
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Next enter a Document Library, the default value is Zetadocs.  Note: If using the Zetadocs Archive Service this
value should be left set to the default value Zetadocs.
Set the library Folder Name Structure, this subdivides archived documents into subfolders in the SharePoint
document library based on information from the sent record.
You have three levels to work with and can choose the following options:
o COMPANY – The recipient NAV Customer name. e.g. Cronus Inc
o DATE – The Date with a format specified by the Date Folder Naming property below. e.g. 30/03/2013
o DOCTYPE – The Document Type as specified for the current Zetadocs Document Set, or its override in the

Zetadocs Report Settings. e.g. Sales Orders. Note: This is not the SharePoint content type.
When using Date you need to specify the Date Folder Naming, this specifies the date format e.g. YYYY-MM-DD,
DD-MM-YYYY, MM-DD-YYYY etc. 
If you have installed the NAV 2013 R2 Web Client Document FactBox, check Load Document FactBox without
document list, so that NAV Web Client pages display more quickly on systems using slower data stores (e.g.
SharePoint Online). This option is also applied to the NAV Windows Client when using Web Client Document
FactBox in server only deployments.
If you are using SharePoint archiving input the SharePoint site or site collection address as required. This is the
bold section shown here: https://equisys.SharePoint.com/sites/MicrosoftDynamics/default.aspx.

Note: You can click the button located at the end of the SharePoint Site field to verify it.
The SharePoint Document Workflow option allows you to submit documents for approval by other SharePoint
users, check this option should it be required.
If you are using the Zetadocs Archive, enter the server name on your network where the Zetadocs Archive Service
has been installed into the Service Address field e.g. http://example-server/ZetadocsArchive ensuring there are
no spaces in the name.
Once you have added the service address click the test button at the end of the field to verify it, this will open a
browser window and if successful in connecting to the service it will display a page titled ArchiveService Service
with the confirmation message You have created a service below it.

Updating the Zetadocs Report Settings to match your Reports

The Zetadocs Standard Configuration data points at the default report objects, you now need to adjust this to match
your report id’s as specified during the report modification steps.

For NAV 2013/2013 R2: Open the Windows Client and in the Navigation Pane select Departments  > 
Administration > Application Setup > Zetadocs Setup  >  Zetadocs Report Settings.
For NAV 2009: Select the Administration > Zetadocs Setup >  Advanced Settings, then the Zetadocs Report
Settings Card.
Select a report and use the Document Set Name as your guide to the respective report setting.
Select the Report ID field and choose your modified report from the Object list.
Repeat the process for any remaining reports as required.

Note: A report can only be associated with one Zetadocs Document Set but many reports can be associated with
one Zetadocs Document Set.

Setting NAV to run the correct reports

You may now need to set NAV to run the modified reports instead of the original ones by adjusting the Report
Selections in NAV. You do not need to perform this step if you have modified your reports and kept the default
Report IDs. In this example we will set NAV to run the modified Order Confirmation report, this process should be
repeated for each new report being used.

For NAV 2013/2013 R2: Search for Report Selections Sales and select the Order report from the drop down.
For NAV 2009: Open the NAV client and select Administration >  Sales & Marketing >  Report Selections and
choose the Order report.
Click into the Report ID field and select the arrow to open the Objects list.
Select the new object from the list, in this case 9009962 ZD-Order Confirmation.
Repeat as required for the other reports.

Importing the Zetadocs Permissions

Users in NAV need to be granted permissions to access and edit fields, this also applies to the additional Zetadocs
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NAV objects. As such you now need to add permissions to allow users access to the Zetadocs elements in NAV.

For NAV 2013 and NAV 2013 R2
Search for Configuration Packages in the Windows Client and open the Configuration Packages page. 
Select Import Package… from the Process group on the Home tab.
Locate the Zetadocs for NAV Permission Sets and Permissions – NAV 7.00.RAPIDSTART file from your product
download and click Open. 
Select the ZETADOCS entry in the Configuration Packages list and click on Apply Package.
You will be asked to confirm that you wish to apply the data, click Yes to continue and complete the import.

For NAV 2009
Select Administration > Application Setup > Company Setup > Data Migration.
The Migration Overview form will appear, select Functions and then Import from XML.
Go to your product download and browse to the Zetadocs NAV Server Components folder and select the Zetadocs
for NAV Roles.xml file.
On the Migration Overview form, select the Migration button and then Apply Migration Data.
Repeat this process to import and apply the Zetadocs for NAV Permissions.xml file.
Next select Tools >  Security >  Synchronize All Logins.

Assigning Users Permissions

For NAV 2013 and NAV 2013 R2
In the Windows Client search for the User Setup page.
Click the Edit List option and select a user from the User ID drop down.
Click Edit to open the User Card and scroll down to the User Permission Sets fast tab, select an empty row and add
the required permission sets from the options below. 
o ZETADOCS - grants access to the standard Zetadocs pages, forms and tables and allows you to use Zetadocs

for NAV. 
o ZETADOCS ADMIN - grants the user the ability to adjust the setup of the system in more fundamental ways and

should be reserved to administrators only.
Click OK when finished and repeat for the remaining users.

For NAV 2009
Click Tools > Security >  Roles.
Select the Zetadocs role you want to from the options below and click the Role button and select the Windows
Logins option.
o ZETADOCS - grants access to the standard Zetadocs pages, forms and tables and allows you to use Zetadocs

for NAV. 
o ZETADOCS ADMIN - grants the user the ability to adjust the setup of the system in more fundamental ways and

should be reserved to administrators only.
To add a Windows user or group to the list, select an empty row.
In the Login ID field, click Assist and the Windows Logins window appears. 
Select the user you want to assign this Zetadocs role to and click OK.
This user or group will now be added to the list shown in the Windows Logins window for this role, repeat for any
remaining users.
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Delivery Essentials Configuration
The configuration data imported earlier will have provided a basic working system that should be capable of sending
reports from NAV to recipients and archiving them. This chapter covers how you modify the configuration to fulfill
your specific requirements. For further information on any field in the settings simply press F1 with it selected. You
should have already configured the Zetadocs General Settings during the configuration import earlier, so we can
proceed with customising the Delivery settings.

1. Delivery Settings

The Zetadocs Delivery Settings are only relevant to Delivery Essentials users and enable you to specify options
applied to documents on sending.  This does not include addressing or delivery method, which are determined using
the Delivery Rules but covers the standard actions that will be applied to all sent items.

To access the Delivery Settings in NAV 2013 and NAV 2013 R2:
Open the Windows Client and in the Navigation Pane select Departments  >  Administration > Application Setup
> Zetadocs Setup  >  Zetadocs Delivery Settings.

To access the Delivery Settings in NAV 2009:
Open the Development Environment and navigate to Administration > Application Setup > Zetadocs Setup >
Zetadocs Delivery Settings.

General Settings
Fax Enabled: Requires the installation Zetafax. If you have Zetafax installed check this option.
Reference Prefix: The reference prefix is printed onto documents sent using Zetadocs, it can be a maximum of 15
characters long.

Sent Items Settings
Archiving Sent Items Enabled: Checking this box results in documents, sent using Zetadocs PDF, being archived in a
central shared network folder. This occurs in addition to any SharePoint  or Zetadocs archiving you may have
configured earlier.
Archive Location: The location of the shared network folder for archiving, it requires a suitable network folder
location. You must also ensure that all Zetadocs enabled users have permission to access this folder. Note: This
option does not support any of the Zetadocs for NAV search features which require SharePoint integration.
Folder Name Structure: Subdivides archived documents into subfolders of the SharePoint document library based
on information from the sent record. You can specify up to three of these values to generate your file plan using the
Folder Option 1, 2 and 3 fields.
o COMPANY – The recipient NAV Customer name
o DATE – The Date with a format specified by the Date Folder Naming property
o DOCTYPE – The Document Type as specified for the current Zetadocs Document Set, or its override in the

Zetadocs Report Settings
Date Folder Naming: Allows you to specify the format of the date folder structure in the SharePoint archive. E.g.
YYYY-MM-DD, DD-MM-YYYY, MM-DD-YYYY etc.
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2. Document Templates

The final area of system settings we need to configure are the Template settings, however before looking into the
settings it is recommended that you first familiarise yourself with templates and what they can offer your system. 
Zetadocs Templates combine stationery overlays and attachment documents as well as supplementary addressing
for any document sent using that template from the Zetadocs Client.

Note: If you are installing in a language other than English you should first check the templates folder of your
product download as it contains a folder with sample templates specific to your language. 

Document Template Features

Attachments: The document template can include an attachment to allow you to include your own company specific
documents like terms and conditions etc. This is in addition to the copy of the document being sent.
Stationery: A single stationery file can be used to add the companies branding to all documents being sent out.
Message Body Text: The message body text contains the email message body and subject, this can be used with
dynamics fields to populate information from NAV automatically into the email reducing the time required to process
business documents. 

Sample Templates

To speed the setup of your system we have provided a set of generic templates which can be used to quickly get
you up and running, these contain. 
Attachments: No default attachments are included with the sample templates.
Stationery: The sample templates all point to the same stationery file meaning that by updating this one file to
match your companies existing documentation all documents sent by the system will be branded.
Message Body Text: A default email message is provided for the main document types, with dynamic fields
automatically populating it with key data, shown in red below.

Subject: Order Confirmation for order number: 300381 for Equisys Ltd

Message Body:
FAO: John Smith

Dear Customer, 
I'm pleased to attach your order confirmation, reference number 300381. 
Kind regards, 

Sales Team

For details on adjusting the Zetadocs Templates open the Zetadocs Client and view the help files.

3. Template Settings

Zetadocs Templates combine stationery overlays and attachment documents as well as supplementary addressing
for any document sent using that template from the Zetadocs Client. Zetadocs will already have created entries for
each type of report supported, these can be modified in the Zetadocs Client, the section on document templates
explains this further. 

To access the Template Settings in NAV 2013 and NAV 2013 R2:
Open the Windows Client and in the Navigation Pane select Departments  >  Administration > Application Setup
> Zetadocs Setup  >  Zetadocs Template List.

To access the Template Settings in NAV 2009:
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Open the Classic client and in the navigate to Administration > Application Setup > Zetadocs Setup >
Advanced Settings > Zetadocs Templates.

Available Options
Template ID: The ID specific to this particular template. 
Path: Contains the path to the folder which stores your templates. 
Name: Contains the filename of the template to be used. 
Description: A description of the template to help you identify it.

Should you wish to change the template a report uses, for example if you wished to send out Sales Orders for a
period with special attachment and message as part of a special offer. Then you can create additional templates in
the Zetadocs client and assign them by doing the following.

Create a new template based upon the existing Sales Order Template using the Zetadocs Client, the Client has
help files with details on how to do this, this allows you to edit the email message to inform customers of the
special offer and change the attachment for one with details of the offer. 
Next open the Windows Client and in the Navigation Pane select Departments >  Administration > Application
Setup > Zetadocs Setup > Zetadocs Template List

Fields
Template ID: The ID specific to this particular template. 
Path: Contains the path to the folder which stores your templates. 
Name: Contains the filename of the template to be used. 
Description: A description of the template to help you identify it.

To use a new template:
Choose the Template you wish to modify and select OK.
Select the Path option and enter the location of the new template.
The name field will automatically populate, add a suitable Description and close the window.
Any documents which would have been sent with the previous template will now make use of the new one.

This completes the setup of the standard delivery settings which apply across all documents, at this point your
system should be setup to send out your business documents with the correct stationery, attachments and a email
personalised by dynamic fields. The next level of customisation allows you to specify how each type of document is
handled and how specific customers or vendors have their document delivered. The next section will introduce
delivery rules.

4. Introducing Delivery Rules

When printing a Zetadocs enabled report, Zetadocs analyses each record in turn against the Delivery Rules. These
include details such as the recipient, delivery method (Email, Fax, Hard Copy), Archiving settings and the template to
apply. Zetadocs rules come in four levels. On printing a document to Zetadocs the rules are applied in ascending
order. 

Rules Levels:
1. The Default Rule – a basic rule that can be used by any Zetadocs enabled report.  
2. Per Document Set – specific settings for Zetadocs enabled documents by type.
3. Per Company – specific settings for Zetadocs enabled documents by company.
4. Per Company, per Document Set – specific settings applied to specific document types when sent to a

specific company.
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5. Testing Delivery Essentials

Activating Test Mode

When testing Zetadocs you can either create dummy records or readdress them as part of the test or you can place
reports test mode, this will stop the report being sent to the Zetadocs Client for delivery. This allows you to test the
system without sending documents to customers.
To access the Report Settings in NAV 2013 and NAV 2013 R2:

Open the Windows Client and in the Navigation Pane select Departments  >  Administration > Application Setup
> Zetadocs Setup  >  Zetadocs Report Settings.

To access the Report Settings in NAV 2009:
Open the Development Environment and navigate to Administration > Application Setup > Zetadocs Setup >
Advanced Settings > Zetadocs Report Settings.
Select the report you wish to put into test mode and locate the Test mode checkbox.
Ensure this is ticked for each report you are testing, you will need to undo these steps once testing is complete.

Zetadocs for NAV Document Delivery

Create a dummy entry in NAV e.g. a sales order and print it to Zetadocs, address it to yourself and send the
document. Ensure it arrives and displays as expected, before navigating to your archive and ensuring it has been
archived. 

Single Send
Select the Administration option in the Navigation pane and then Application Setup, open the Zetadocs Setup
section and select the Zetadocs System Rule Card, or search for it in the NAV 2013 Windows Client.
Select the document set relevant to the report you are testing e.g. Sales Orders. 
Select the Sales and Marketing option in the Navigation pane.
Open the Order Processing section and select Orders, or search for it in the NAV 2013 Windows Client.
Select or create a suitable order record and select Print  >  Order Confirmation, a print dialog will appear, select
Print.
The Zetadocs Delivery card may appear (shown below) depending on your system settings, this will contain all of
the delivery details according to your current rule setup.
Select OK to send the report, check to ensure it delivers and archives as expected.

Batch Send
Open the Order Processing section and select Orders.
Select a suitable range of records and select Print  >  Order Confirmation.
The usual print dialog will appear, select Print.
The Zetadocs Batch Delivery card may appear depending on your system settings, this will contain all of the
delivery details according to your current rule setup.
Select OK to send the reports, check to ensure they deliver as expected and archive if this has been configured as
well. 

Testing Optional Delivery Features

SharePoint Archiving Support
The archive should already have been populated whilst performing the earlier document delivery and rule tests. As
such viewing the document library created earlier should display the archived items. 

Checking Zetadocs Form and Zetadocs Archive option additions to NAV
You will need to perform this test if you have imported the Zetadocs for NAV Interfaces .fob file or performed the
equivalent manual steps. The fob file will have added the menu items to the following locations, we would
recommend you test a selection of them as a minimum using both the Role Tailored and Classic clients as
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applicable.

The Zetadocs Archive search menu item can be added to the cards listed in the table below:

Form No. Form Name

21
26
41
42
43
44

507
6630
130
132
134

6660
49
50
51
52

509
6640
138

6650
140
136

Customer Card
Vendor Card
Sales Quote
Sales Order

Sales Invoice
Sales Credit Memo

Blanket Sales Order
Sales Return Order

Posted Sales Shipment
Posted Sales Invoice

Posted Sales Credit Memo
Posted Return Receipt

Purchase Quote
Purchase Order

Purchase Invoice
Purchase Credit Memo

Blanket Purchase Order
Purchase Return Order

Posted Purchase Invoice
Posted Return Shipment

Posted Purchase Credit Memo
Posted Purchase Receipt

The Zetadocs Rules menu item can be added to the cards listed in the table below:

Form No. Form Name

21
26

Customer Card
Vendor Card

Open NAV and choose one of the cards above e.g. the Customer Card.
Click on the Customer button and it will expand revealing a number of options.
Zetadocs Archive and Zetadocs Rules should appear at the bottom of this list as shown in the figure below.
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Capture Essentials Configuration
In this section we will install the Zetadocs Server and go through its configuration options, please ensure you have
carried out the steps in the Delivery Essentials Setup, as many of its components are required to support capture.
Systems which are not using Capture Essentials can skip this section.

Main Steps:
1. Installing the Zetadocs Server
2. Configuring Document Queue Options
3. Configuring Capture Settings

1. Installing the Zetadocs Server

The Zetadocs Server monitors network folders setup for document queues and converts documents added to that
folder to PDF/A format  before placing them in the document queue.

Go to the Zetadocs Setup program and select your Zetadocs product version.
Next select the Zetadocs Server option to start the installer.
Click Next and choose a destination folder for the installation and then Next.
 You will be asked to choose whether you want to include OCR support, this feature requires additional Zetadocs
licencing either the Supplier Invoice Processing, Proof of Delivery or Capture Plus modules as well as an Abbyy
licence.
Choose the relevant option for your install and complete installing the Zetadocs Server.
o I have an Abbyy licence and would like OCR support. 
o I do not have an Abbyy licence number.

Installing OCR Support

OCR support is provided using the third party solution provided by Abbyy, follow the steps below if you are installing
OCR or barcode support, otherwise continue onto the next step.

Click Next, if you have included Abbyy OCR you will be asked to review their licence agreement.
Once you have reviewed and selected I Agree, click Next.
The Installation Wizard is now ready to install the Zetadocs Server, select Install and the wizard will complete the
install.

Licensing Abbyy FineReader
Note: This requires an Abbyy licence.

If you earlier specified that you wished to include Abbyy OCR support then you now need to license the Abbyy
FineReader Engine.
The Abbyy License Manager will open automatically.
Click the Add new... button and then add your Abbyy license number and click Add.
The Abbyy FineReader Activation Wizard will appear for you to activate your product.

Activation methods: 
Via the Internet - Activation is carried out automatically and takes only a few seconds. An Internet connection is
required for this type of activation. 
By e–mail - The user needs to send an e–mail message generated by the program and containing information
required for activation. To ensure a quick reply from the mail robot, do not alter the information in the message
body or Subject field. 
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1. Installing the Zetadocs Server

The Zetadocs Server monitors network folders setup for document queues and converts documents added to that
folder to PDF/A format  before placing them in the document queue.

Go to the Zetadocs Setup program and select your Zetadocs product version.
Next select the Zetadocs Server option to start the installer.
Click Next and choose a destination folder for the installation and then Next.
 You will be asked to choose whether you want to include OCR support, this feature requires additional Zetadocs
licencing either the Supplier Invoice Processing, Proof of Delivery or Capture Plus modules as well as an Abbyy
licence.
Choose the relevant option for your install and complete installing the Zetadocs Server.
o I have an Abbyy licence and would like OCR support. 
o I do not have an Abbyy licence number.

Installing OCR Support

OCR support is provided using the third party solution provided by Abbyy, follow the steps below if you are installing
OCR or barcode support, otherwise continue onto the next step.

Click Next, if you have included Abbyy OCR you will be asked to review their licence agreement.
Once you have reviewed and selected I Agree, click Next.
The Installation Wizard is now ready to install the Zetadocs Server, select Install and the wizard will complete the
install.

Licensing Abbyy FineReader
Note: This requires an Abbyy licence.

If you earlier specified that you wished to include Abbyy OCR support then you now need to license the Abbyy
FineReader Engine.
The Abbyy License Manager will open automatically.
Click the Add new... button and then add your Abbyy license number and click Add.
The Abbyy FineReader Activation Wizard will appear for you to activate your product.

Activation methods: 
Via the Internet - Activation is carried out automatically and takes only a few seconds. An Internet connection is
required for this type of activation. 
By e–mail - The user needs to send an e–mail message generated by the program and containing information
required for activation. To ensure a quick reply from the mail robot, do not alter the information in the message
body or Subject field. 

2. Configuring Document Queue Options

Zetadocs comes with two Document Queues setup a standard, a Sales and a Purchase Document Queue, with other
custom queues available with Capture Plus. To configure the Zetadocs Server to communicate with the document
queues these first need to be configured.

Creating the Document Queue Folders

Each document queue requires a network folder into which captured documents are placed for processing and
conversion, and to which all users of the queue have full access permissions. 

Create the required folders e.g.  Sales Document Queue.
View its Properties and ensure the Share this Folder radio button is checked.
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Select the Permissions button and assign the necessary permissions.
o USERS: Share permissions with a minimum of Change and Read Permissions. Full Permissions are

recommended.
o SERVICE: The Zetadocs DIRMonitor Service must have access to the queue folders. To do this add FULL

Permissions to the SYSTEM user or whatever network user the service is running as.

Document Queue Settings in NAV

The Zetadocs Document Queue card will have been populated by the configuration file imported earlier with default
values. 

For NAV 2013 and NAV 2013 R2 navigate to Administration > Application Setup > Zetadocs Setup  > Zetadocs
Document Queue List.
For NAV 2009 navigate to Administration > Application Setup > Zetadocs Setup  > Zetadocs Document Queue
Setup.
Select the Queue you wish to adjust, it will contain the following fields. 
o No.:  The document Queue ID, can be left as is.
o Name: The name of the Document Queue, edit as required.
o Path: The location of the document queue folder you created in the previous step, enter in the format \

\ExampleServerName\Sales Document Queue\
o Archive Documents: Checking this option means all processed documents will be archived.
o Archive Original: Checking this option means Zetadocs will archive the original document rather than the

version converted to pdf. The conversion will still take place ensuring that any OCR or barcode recognition is
still performed.

o Delete After Archive:  Checking this option means documents will be deleted from the document queue after
being successfully archived.

o Show Delete Confirmation: Checking this option determines whether a user is to be asked to confirm deletion of
documents.

o Auto Link Documents: (Not supported with Capture Essentials) Checking this option enables Auto Link
functionality. This determines whether the document queue will call the GetAutoLink function in the Zetadocs-
Send Customize codeunit. This option need to be checked if you are intending to use OCR or barcode matching.

o Check Out on View: Checking this option means that when documents are viewed in the document queue they
are also checked out.

The list at the bottom of the Document Queue card shows the menu items available to the user, when they click the 
Archive button from the Zetadocs Document Queue form. 

The Zetadocs Server Configuration File

The Zetadocs Server settings are modified using a Config.xml file, this is located in the Zetadocs Server installation
location usually C:\Program Files (x86)\Zetadocs Server\Document Converter. Open this file in a text editing program
such as Notepad.exe. The Config.xml file contains settings which govern how documents are captured and added to
document queues. Therefore it consists of instructions for each document queue configured and more general
options for capturing documents. We will go through those options relevant to an Essentials install in the order they
appear, for any options not described Essentials users can leave them set to the default values.  In the example
below there is a Sales and a Purchase Document Queue each inside its own <DocsQ> </DocsQ>tags with the
general Zetadocs Server settings below that at the bottom which applies to all queues.  In this section we will go
through the document queue specific options identifying what the options do and providing suggestions for
recommended defaults, please go through each in turn to ensure your system is configured properly. 

<?xml version="1.0" encoding="utf-8"?>
<Config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://
www.w3.org/2001/XMLSchema">

  <docsQueue>
     <DocsQ Description="Sales Document Queue" Location="\\User specified queue location
\Sales Document Queue\">
      <EnablePDFTextExtractionToFile>false</EnablePDFTextExtractionToFile>
      <BatchScanSplitType>Barcode</BatchScanSplitType>     
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      <BatchScanPageInterval>1</BatchScanPageInterval>                            
      <BatchScanBarcodePrefix></BatchScanBarcodePrefix>                       
      <BatchScanBarcodeDeleteSplitPage>false</BatchScanBarcodeDeleteSplitPage>
      <FilenamePrefix></FilenamePrefix>    
   </DocsQ>
    
    <DocsQ Description="Purchase Document Queue" Location="\\User specified queue location
\Purchase Document Queue\">
      <EnablePDFTextExtractionToFile>false</EnablePDFTextExtractionToFile>
      <BatchScanSplitType>Off</BatchScanSplitType>                                
      <BatchScanPageInterval>1</BatchScanPageInterval>                                  
      <BatchScanBarcodePrefix></BatchScanBarcodePrefix>                           
      <BatchScanBarcodeDeleteSplitPage>false</BatchScanBarcodeDeleteSplitPage>
      <FilenamePrefix></FilenamePrefix>        
    </DocsQ>
 
  </docsQueue>
  
  <PDFQuality>Better</PDFQuality>
  <EnableAbbyy>true</EnableAbbyy>
  <StellentTimeOut>10</StellentTimeOut>
  <StellentBypassPDF>true</StellentBypassPDF>
  <LogLevel>Error</LogLevel>                                                      
  <LogToFile>true</LogToFile>
  <LogToEventLog>false</LogToEventLog>
  <EnableBarcodeDetection>true</EnableBarcodeDetection>
</Config>

WARNING: The Zetadocs Server Config.xml file is case sensitive, therefore when setting the various options please
ensure that you copy the exact casing shown here. Failing to do so may prevent the server from working as
intended.

Specifying Document Queue Locations in the Zetadocs Server

Items added into the Document Queue folders will be processed and converted to PDF/A format. Document Queue
folders should be folders on the local machine where the Zetadocs Server is installed. The folder should then be
shared on the network for Document Queue users to access.  

Sample Code: <DocsQ Description="Sales Document Queue" Location="\\User specified queue
location\Sales Document Queue\">

Options:
<DocsQ Description="Sales Document Queue" - Enter the name of the queue as specified in NAV earlier, it
is already set to the default value.
Location="\\User specified queue location\Sales Document Queue\"> - Enter the Path to this
queue as specified in NAV earlier on the Zetadocs Document Queue card.

PDF Text Extraction

This option allows you to set the Zetadocs Server to extract text which can then be used by several Capture and
Delivery Plus elements, Essentials users can leave this set to the default value of false. 

Sample Code: <EnablePDFTextExtractionToFile>false</EnablePDFTextExtractionToFile>

Options:
true - Causes the Zetadocs Server to attempt to extract text from documents, activating this option will slow down
the Zetadocs Server operation.
false - This option stops the Zetadocs Server extracting text from documents.
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Batch Scanning Settings

Each document queue can be configured to use only one type of splitting method when processing batches of
documents. Select from the options below depending on how you wish to split batches, if at all.

Sample Code: <BatchScanSplitType>Off</BatchScanSplitType>     

Options:
Off - The default, the Zetadocs Server doesn’t process any batches present in the Batch Split folder of your
document queue treating them as a single document.
Barcode - (Not supported with Capture Essentials) The Zetadocs Server splits the batches on every page that
contains a barcode.
BarcodeValue - (Not supported with Capture Essentials) The Zetadocs Server splits the batches every time the
barcode being read has a different value to the previous barcode read.
PageInterval - Zetadocs Server splits the batches using an interval defined by the BatchScanPageInterval
parameter, e.g. every 3 pages see below for details.

Configuring the Page Interval

This value determines the page interval number to be used when processing a document using the PageInterval
splitting method described above.

Sample Code: <BatchScanPageInterval>1</BatchScanPageInterval>    

Options:
The page interval can be any positive whole number value (integer) e.g. 1,2,5,10,20 etc. The batch will then be split
into documents each that number of pages.
For those not using page interval splitting we recommend adding the value 1, as this will be ignored unless the
BatchScanSplitType has been set to PageInterval.

File Name Prefix

It is often useful to be able to identify which Document Queue a document originated from following the conversion
and queue processing. The file name prefix settings allows you to prefix all files processed by a queue. For example,
a prefix setting of “SDQ_” in the Sales Document Queue would result in a document “Sample.doc” becoming
“SDQ_Sample.pdf” after conversion to PDF.

Sample Code: <FilenamePrefix></FilenamePrefix> 
Options: The default is no prefix. To set a prefix put the appropriate prefix in the setting for the desired queue. We

recommend that the prefix value be less than 10 characters and the following characters are not allowed: # % &

* : < > ? / { | } ~ " '

That completes the Zetadocs Server settings for a document queue, this process should be repeated for all
subsequent queues before continuing on to the general capture options.

3. Configuring Capture Settings

The general capture options for the Zetadocs Server are located at the bottom of the Config.xml file and contain the
options listed below, these are applied to all captured documents regardless of the document queue settings.

Adjusting the PDF Quality

The quality of the pdf’s the Zetadocs Server produces during conversion can be adjusted to meet your requirements
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of file size, quality and conversion speed. 

Sample Code: <PDFQuality>Better</PDFQuality>

Options:
Better - Use this option when pdf quality is important, e.g. when using OCR.
Smaller - Use this option when storage space is at a premium and high resolution is not required.

StellentTimeOut Option

Stellent is a component that helps with pdf conversion, this setting determines the duration Zetadocs will wait
before assuming it has a problem and aborting the conversion.

Sample Code: <StellentTimeOut>10</StellentTimeOut>
Options: We recommend that this setting is left at its current default of 10.

StellentBypassPDF Option

This option causes the Zetadocs Server to bypass pdf files added to the conversion folder rather than convert them
again. They are instead simply copied to the converted folder, which can result in the Server operating more quickly
on a given batch of documents. Note: The PDF files may not be in the specific PDF/A format generated by the Server.

Sample Code: <StellentBypassPDF>true</StellentBypassPDF>
Options:

true - The recommended default as PDF files will no longer be converted which can increase the speed at which
the Zetadocs Server can process a batch of documents.
false - Sends all documents for conversion including those already in pdf format.

Adjusting the Logging Level

The logging level options can normally be left set to error, with the other options only used in troubleshooting and
support cases.

Sample Code: <LogLevel>Error</LogLevel>      

Options: 
Error- Use this setting for general operation.
Warning - Use this for trouble shooting issues.
Debug - Should be used for a controlled period of time to trouble shoot issues.   

Specifying the Log Location

The Zetadocs Server log can be set to save to a file and/or the event log, this is done using the two options 
<LogToFile> and <LogToEventLog>. Using these options is is possible to set Zetadocs to log to either a file or
the event log or neither.

The Zetadocs Server log file is written to: C:\Windows\Temp\Zetadocs\ZdDocumentConverter.log

Sample Code: <LogToFile>true</LogToFile>

<LogToEventLog>false</LogToEventLog>
The above code would result in the log being kept in Zetadocs Server log file.

Options: Each of the can be set to either true or false, we recommend that you have one or the other forms of
logging active at all times.

true - Logs event at the level specified above to the log file or event log.
false - Stops the Zetadocs server logging events into the log file.



25Capture Essentials Configuration

© 2014 Equisys Ltd

Restarting the Zetadocs Server

Save the updated Config.xml file when you have finished making your changes.To implement the changes you have
made you need to restart the Zetadocs Server. 

Go to Start > Run, then enter Services.msc
Scroll to Zetadocs Document Converter and right click on it and select Restart.

4. Testing Capture Essentials

Drag and Drop with the Documents Factbox

Log into the Windows Client as a user with a role with access to the modified sections within NAV.
Locate one of the modified pages setup to work with Zetadocs e.g. Sales Order
Open one of the modified pages in NAV and this will display the Documents FactBox in the top right hand side.
Drag and drop a document to the Drage Files Here area and release it.
Open the SharePoint archive for the system and search for the original NAV record.
This should display the document you dragged and dropped into the Documents tab.
Repeat this with a selection of file types and from locations like the Outlook inbox to ensure they function as
expected.

Check Scanning (Optional)
If a scanning device is connected, perform the following checks to ensure correct operation.

Click the Queue  >  Scan... button to initiate scanning which uses the Zetadocs Client settings.
Scan a document; once complete the scanned document name should appear in the Zetadocs Document Queue
as the latest entry. The file (typically “filename.pdf”) should also be in the Zetadocs Document Queue shared
folder location.

Check Shared Location Updating
Create an email with an attachment and save it as a .msg file into the Zetadocs Document Queue’s shared folder
location.
Select the Queue > Refresh menu button and ensure that the saved email.msg file is now in the Document
Queue converted into pdf format.
Select the entry in the Zetadocs Document Queue and click Item > View, ensure that the item is viewable in pdf
format
Select the entry in the Zetadocs Document Queue and click Item > View Original, ensure that the item is
viewable in its original format.

Check Printing
Select the scanned .pdf file and click Item > Print, when prompted select a physical printer and click print. Ensure
that the document prints to the printer.
Select the recently added email with attachment(s) now stored as a pdf file and click Item > Print, when
prompted select a physical printer and click Print. Ensure that the document prints to the printer and that the
attachments are printed out also.

Check Delete
Select an entry in the Zetadocs Document Queue and click Item > Delete.  Ensure that the document is removed
from the Queue and also that it successfully deletes the file from the Zetadocs Document Queue network folder
location.

Creating Documents using the Sales and Purchase Document Queues

The Sales and Purchase Document Queues have the capacity to generate a number of different documents within
NAV. These are predetermined and you should do a test for each that you intend to implement in the system. 
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Creating a Document using the Sales and Purchase Document Queues
Open NAV and open the Zetadocs Sales Document Queue.
Ensure the queue is populated with a selection of sample or test documents.
Select one of the items from the queue and select Create and then the type of document you wish to test. In this
case we’ll look at a Quote, normally a user would view a queue item using the Zetadocs Viewer and use this as
the basis for filling in the quote, order invoice etc details. 
This will display the Sales Quote window. Fill in the form as usual and when finished click the Print button.
This displays the Sales - Quote dialog box. To send your documents using Zetadocs, check that Send using
Zetadocs is selected on the Options tab.
Click Print again. This displays the Sales – Quote - Print dialog box. Click OK. This displays the Zetadocs Delivery
window, where you can change any settings if you want to, e.g., if you want to address your quote to a different
contact, or if you want to change the template. 
On the Zetadocs Delivery window, if you select Preview in Zetadocs Client before sending, this allows you to
preview your document in the Zetadocs Client before actually sending it. But if you do not select this option, your
document is sent directly to the recipient.
After sending the order, the Send Result dialog box is displayed, showing you the result. If you click the Show log
button, you can see information about the Quote you sent, and it will also tell you the location where the Quote
has been archived as per your archiving options in Microsoft SharePoint.
You can now close the Sales Quote window. The Zetadocs Status Message is displayed advising you that a copy
of your document that you have just processed from the Zetadocs Document Queue, has been saved in the
archive and will also give you the archive location in Microsoft SharePoint. You will be asked whether you want to
delete the document from the document queue. If you no longer require the document to be in the Document
Queue, you can delete it. You can always go back to the Microsoft SharePoint location where the document was
saved to view it.
Repeat this process for the other Sales items and the Purchase queue as required.
Open your SharePoint Archive and ensure the documents have been archived as expected.

Web Client Document FactBox Testing

If you have installed the NAV 2013 R2 Web Client Document FactBox, perform the following checks to ensure correct
operation.

Open the NAV Web Client and navigate to and open a Sales Quote record, or other supported record type. 
Select Add from the Documents FactBox Menu (…) actions and browse for an item to add to the archive using
Windows Explorer or the equivalent on the device. 
Ensure this item appears in the Related Document List and is archived. 

Continuing the Installation

This completes the installation and testing of Zetadocs Delivery and Capture Essentials. If you are not installing any
Advanced features your setup is now complete, should you be performing the install on a test setup please proceed
to the next section migrating to a live environment. 



27Migrating to the live database

© 2014 Equisys Ltd

Migrating to the live database

To migrate your setup to your live system you need to: 
Exporting the Configuration
Exporting any Modified Forms, Pages, Tables and Reports
Importing the Zetadocs for NAV Objects
Importing any Modified Forms, Tables or Reports
Importing the xml file with your configuration

Exporting the Configuration

The Zetadocs Configuration Export form will export all of the configuration data specific to Zetadocs, if you have
modified data in other tables this will not be exported.

From the Navigation pane select the Administration option.
From the options that appear, select Application Setup and then Zetadocs Setup.
Select the Zetadocs Configuration Export option.
In the window that appears select a suitable name and location for your configuration export and click Export. 

Exporting Modified Forms, Pages, Tables and Reports. 
Open the Object Designer (Tools > Object Designer). 
Click on All button in the designer menu. 
Select All objects (CTRL + A) or alternatively select those objects you wish to export. 
Export the Objects (File > Export) to a suitable file e.g.  Zetadocs for NAV6.0 Export.fob file. 
Keep the Zetadocs for NAV6.0 Export.fob in a safe place. 

Importing Zetadocs to the Live NAV System
When moving to the live system instead of importing the config.xml file and pages/tables/forms.fob files straight
from the Zetadocs for NAV product download you simply select the files you created during the exports above. 

Import the Zetadocs for NAV Objects fob file created from you test system
Install the Page interfaces and forms as required
Import the xml file with your configuration from the test system
Copy across your Zetadocs Templates
Install the Zetadocs for NAV Client on the various client machines that will be using Zetadocs

Once you have imported the configuration you should perform a brief series of tests like those conducted earlier to
ensure that the migration has been successful.
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Further Resources

To keep this guide as simple as possible we have focused on the standard installation requirements. The links below
offer access to installation support materials and some more common pieces of non standard installation advice. 

Latest Advice and Resources - Provides access to the latest technotes, updates and tools to support your
installation, we recommend you view this page to ensure you are working with the most up to date software and
advice. Also provides general advice and specific advice for special install scenarios, such as Upgrades, Group
Policy and Remote Desktop Services installations. 

Installation Videos - Video demonstrations of how to perform Zetadocs for NAV installations.

http://www.equisys.com/support/knowledgebase/zdnav.htm
http://www.equisys.com/support/knowledgebase/zdnav_videos.htm
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